4 responses

  1. James
    February 9, 2011

    Paul you play too many games and it’s all you post about

  2. Steampunk Jammer
    February 9, 2011

    THis migh actually be of some use to me if I was actually able to afford to upgrade my OS so I can run the game. Lame how Apple is limiting it users, or maybe forcing those who want to play this game upgrade.

    • chz
      February 9, 2011

      why not install 10.6.6? is it a hackintosh?

  3. Steampunk Jammer
    February 11, 2011

    @chz:Not sure who your comment is directed to, but didn’t I say I cannot afford it?

Leave a Reply

 

 

 

Back to top
mobile desktop